EspañolDeutschFrançaisItalianoPortuguêsРусскийΕλληνικά日本語中文(简体)हिन्दी; हिंदीالعربية
设置为默认语言
PF 问题 - 论坛

如何使用拾色器, 或可湿性粉剂颜色选取器, 在 WordPress 管理

PHP 编程  
 
如何使用拾色器, 或可湿性粉剂颜色选取器, 在 WordPress 管理

如果您使用 WordPress 和使事态的发展 插件 o 主题 为此平台 CMS, 通常知道, 加上部分视觉看到时访问网站的用户, 任何的插件或者主题是的一部分 配置 o 行政管理, 它是由行政部分 WordPress.

通常我们称之为 后端, 和它是一部分, 这虽然不是由用户可见, 它是一部分的插件或主题,我们的 发展, 是在哪里它执行其管理和配置.

以及, 当我们开发的一部分 行政管理 我们的插件或者主题, 很可能是某一时刻你缺乏 颜色选取器, 或者也叫 WP 颜色选取器. 这不是什么更多 web 对象 什么, 当你点击它时候, 显示 颜色范围, 使它能够在方式中选择其中之一 直接 在画布上, 或也通过其 RGB 代码.

如何使用拾色器, 或可湿性粉剂颜色选取器, 在 WordPress 管理 - 图像 1 - 教授-falken.com

方便了 很多事情, 因为它不是一样有那 直接进入 一个 在十六进制 RGB 代码 在文本字段中, 若要选择 调色板中的颜色 我们喜欢颜色. 由什么为此, 我们将使用 颜色选取器.

窗体 添加 一个 颜色选取器 一页 行政管理插件 o 主题WordPress 够了 简单. 首先, 只需添加到 尾巴样式和脚本 样式和脚本 ‘WP-颜色选取器‘, 通过以下方式:

随后, 要使用 颜色选取器, 添加标记 输入 类型 文本 那如井:

正如你可以看到, 我们为其指定一个 到此元素, 有称 ‘颜色拾取器版本‘. 我们用这个名字对于清晰, 但您可以使用 你想要的名字, 如果你在下一步中使用 一样.

要考虑其他字段是 ‘数据默认颜色‘ 这指示的颜色,, 默认情况下, 它将采取 WP 颜色选取器.

完成, 你将不得不 调用, 通过 jQuery, 里面的标签 脚本, 通过以下方式:

在哪里 颜色拾取器版本 指示 我们已分配给 输入的元素 我以前已经创建了.

曾经做过, 如果打开的页面,你正在开发, 你会看到你前面创建的输入的元素应该是在哪里, 显示 颜色选取器 o WP 颜色选取器. 如果 在它, 是 显示 一个 调色板中的颜色 你希望从你可以选择颜色, 和谁 价值 将保存在该属性中 价值 元素 输入 以前创建.

如何使用拾色器, 或可湿性粉剂颜色选取器, 在 WordPress 管理 - 图像 1 - 教授-falken.com

在这种方式,您可以 添加 管理的一个组成部分或 行政管理 任何 主题或插件 您正在创建, 一个 颜色选取器, 避免你 因此不必与合作 十六进制 RGB 代码 这乍看之下不可能给你一个想法是什么颜色.

加入的频道 电报

我们的留言或输入到论坛
Share on Facebook Tweet about this on Twitter Share on Google+ Pin on Pinterest Share on Reddit Share on VK Share on StumbleUpon Share on Tumblr Share on LinkedIn Email this to someone Print this page

相关的文章

2 思考"如何使用拾色器, 或可湿性粉剂颜色选取器, 在 WordPress 管理

Cesar

你好, actualicé mi wordpress y el cuadro conde se escribe el hexadecimal desaparecio lo que me ha costado muchos problemas, saben de como hacer aparecer de nuevo ese cuadro si pueden ayudarme con esa informacion lo agradezco, 此致敬意

答复
    约书亚

    Hola Cesar. Puede que sea alguna incompatibilidad con alguno de los plugins que tengas instalados. El selector de color que comentas, ¿es de algún plugin o de algún tema? Quizás ese tema o plugin no están actualizados a la versión que tienes de WordPress y pueden tener algún bug.

    答复

注释已关闭.